GithubでKey is invalid. It must begin with~~と出る場合の対処法

凄く基本的ですが「Key is invalid. It must begin with ‘ssh-ed25519’, ‘ssh-rsa’, ‘ssh-dss’, ‘ecdsa-sha2-nistp256’, ‘ecdsa-sha2-nistp384’, or ‘ecdsa-sha2-nistp521’. Check that you’re copying the public half of the key」で怒られ、「????????????」となり10分くらい潰したことがあるのでメモ

今回はこのエラーを吐く大半の人が使っているであろうPuTTYGenを利用しました。

このままだと怒られますので

上に「ssh-rsa 」を付けるだけでOKです

ssh-rsaの後に半角スペースが入るので注意してください